Build and install static versions of the libraries
[libftdi] / src / CMakeLists.txt
index 7965999..e1ab82d 100644 (file)
@@ -9,6 +9,14 @@ set(c_headers     ftdi.h)
 
 add_library(ftdi SHARED ${c_sources})
 
+# Static library
+add_library(ftdi-static STATIC ${c_sources})
+set_target_properties(ftdi-static PROPERTIES OUTPUT_NAME "ftdi")
+
+# Prevent clobbering each other during the build
+set_target_properties(ftdi PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+set_target_properties(ftdi-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+
 # Dependencies
 target_link_libraries(ftdi ${LIBUSB_LIBRARIES})
 
@@ -20,6 +28,11 @@ if(${UNIX})
             COMPONENT sharedlibs
             )
 
+   install( TARGETS ftdi-static
+            ARCHIVE DESTINATION lib
+            COMPONENT staticlibs
+            )
+
    install( FILES ${c_headers}
             DESTINATION include/${PROJECT_NAME}
             COMPONENT headers
@@ -34,6 +47,11 @@ if(${WIN32})
             COMPONENT sharedlibs
             )
 
+   install( TARGETS ftdi-static
+            DESTINATION bin
+            COMPONENT staticlibs
+            )
+
    install( FILES ${c_headers}
             DESTINATION include/${PROJECT_NAME}
             COMPONENT headers