Set VERSION and SOVERSION on shared libraries (compatible with versions from the...
[libftdi] / src / CMakeLists.txt
index e1ab82d..0a6a917 100644 (file)
@@ -9,6 +9,9 @@ set(c_headers     ftdi.h)
 
 add_library(ftdi SHARED ${c_sources})
 
+math(EXPR VERSION_FIXUP "${MAJOR_VERSION} + 1")    # Compatiblity with previous releases
+set_target_properties(ftdi PROPERTIES VERSION ${VERSION_FIXUP}.${MINOR_VERSION}.0 SOVERSION 1)
+
 # Static library
 add_library(ftdi-static STATIC ${c_sources})
 set_target_properties(ftdi-static PROPERTIES OUTPUT_NAME "ftdi")