Build and install static versions of the libraries
[libftdi] / ftdipp / CMakeLists.txt
index 63729de..66efc32 100644 (file)
@@ -20,6 +20,14 @@ message(STATUS "Building libftdi++")
 # Targets
 add_library(ftdipp SHARED ${cpp_sources})
 
+# Static library
+add_library(ftdipp-static STATIC ${cpp_sources})
+set_target_properties(ftdipp-static PROPERTIES OUTPUT_NAME "ftdipp")
+
+# Prevent clobbering each other during the build
+set_target_properties(ftdipp PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+set_target_properties(ftdipp-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+
 # Dependencies
 target_link_libraries(ftdipp ftdi ${LIBUSB_LIBRARIES} ${BOOST_LIBRARIES})
 
@@ -31,6 +39,11 @@ if(${UNIX})
             COMPONENT sharedlibs
             )
 
+   install( TARGETS ftdipp-static
+            ARCHIVE DESTINATION lib
+            COMPONENT staticlibs
+            )
+
    install( FILES ${cpp_headers}
             DESTINATION include/${PROJECT_NAME}
             COMPONENT headers
@@ -45,6 +58,11 @@ if(${WIN32})
             COMPONENT sharedlibs
             )
 
+   install( TARGETS ftdipp-static
+            DESTINATION bin
+            COMPONENT staticlibs
+            )
+
    install( FILES ${cpp_headers}
             DESTINATION include/${PROJECT_NAME}
             COMPONENT headers