C++ API: Increase .so library version
[libftdi] / ftdipp / CMakeLists.txt
index 515dc91..27fbe8d 100644 (file)
@@ -1,78 +1,68 @@
 # Check
 set(FTDI_BUILD_CPP False PARENT_SCOPE)
 
-# Includes
-include_directories( ${CMAKE_CURRENT_BINARY_DIR}
-                     ${CMAKE_CURRENT_SOURCE_DIR}
-                     ${CMAKE_CURRENT_SOURCE_DIR}/../src
-                     )
+option ( FTDIPP "Build C++ binding library libftdi1++" ON )
 
 # Targets
-set(cpp_sources   ftdi.cpp)
-set(cpp_headers   ftdi.hpp)
+set(cpp_sources   ${CMAKE_CURRENT_SOURCE_DIR}/ftdi.cpp CACHE INTERNAL "List of cpp sources" )
+set(cpp_headers   ${CMAKE_CURRENT_SOURCE_DIR}/ftdi.hpp CACHE INTERNAL "List of cpp headers" )
+        
+if (FTDIPP)
 
-# Find Boost
-find_package(Boost)
-if(Boost_FOUND)
-set(FTDI_BUILD_CPP True PARENT_SCOPE)
-message(STATUS "Building libftdi++")
+  if(Boost_FOUND)
 
-# Targets
-add_library(ftdipp SHARED ${cpp_sources})
+    # Includes
+    include_directories(BEFORE ${CMAKE_CURRENT_BINARY_DIR}
+                        ${CMAKE_CURRENT_SOURCE_DIR}
+                        ${CMAKE_SOURCE_DIR}/src)
 
-math(EXPR VERSION_FIXUP "${MAJOR_VERSION} + 1")    # Compatiblity with previous releases
-set_target_properties(ftdipp PROPERTIES VERSION ${VERSION_FIXUP}.${MINOR_VERSION}.0 SOVERSION 1)
+    include_directories(${Boost_INCLUDE_DIRS})
 
-# Static library
-add_library(ftdipp-static STATIC ${cpp_sources})
-set_target_properties(ftdipp-static PROPERTIES OUTPUT_NAME "ftdipp")
 
-# Prevent clobbering each other during the build
-set_target_properties(ftdipp PROPERTIES CLEAN_DIRECT_OUTPUT 1)
-set_target_properties(ftdipp-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
 
-# Dependencies
-target_link_libraries(ftdipp ftdi ${LIBUSB_LIBRARIES} ${BOOST_LIBRARIES})
+    set(FTDI_BUILD_CPP True PARENT_SCOPE)
+    message(STATUS "Building libftdi1++")
 
-# Install
-if(${UNIX})
+    # Shared library
+    add_library(ftdipp1 SHARED ${cpp_sources})
 
-   install( TARGETS ftdipp
-            LIBRARY DESTINATION lib${LIB_SUFFIX}
-            COMPONENT sharedlibs
-            )
+    math(EXPR VERSION_FIXUP "${MAJOR_VERSION} + 1")    # Compatiblity with previous releases
+    set_target_properties(ftdipp1 PROPERTIES VERSION ${VERSION_FIXUP}.${MINOR_VERSION}.0 SOVERSION 3)
 
-   install( TARGETS ftdipp-static
-            ARCHIVE DESTINATION lib${LIB_SUFFIX}
-            COMPONENT staticlibs
-            )
-
-   install( FILES ${cpp_headers}
-            DESTINATION include/${PROJECT_NAME}
-            COMPONENT headers
-            )
+    # Prevent clobbering each other during the build
+    set_target_properties(ftdipp1 PROPERTIES CLEAN_DIRECT_OUTPUT 1)
 
-endif(${UNIX})
+    # Dependencies
+    target_link_libraries(ftdipp1 ftdi1 ${LIBUSB_LIBRARIES} ${BOOST_LIBRARIES})
 
-if(${WIN32})
-
-   install( TARGETS ftdipp
-            DESTINATION bin
-            COMPONENT sharedlibs
-            )
-
-   install( TARGETS ftdipp-static
-            DESTINATION bin
-            COMPONENT staticlibs
+    
+    install ( TARGETS ftdipp1
+              RUNTIME DESTINATION bin
+              LIBRARY DESTINATION lib${LIB_SUFFIX}
+              ARCHIVE DESTINATION lib${LIB_SUFFIX}
             )
-
-   install( FILES ${cpp_headers}
-            DESTINATION include/${PROJECT_NAME}
-            COMPONENT headers
+            
+    # Static library
+    if ( STATICLIBS )
+      add_library(ftdipp1-static STATIC ${cpp_sources})
+      set_target_properties(ftdipp1-static PROPERTIES OUTPUT_NAME "ftdipp1")
+      set_target_properties(ftdipp1-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+
+      install ( TARGETS ftdipp1-static
+                ARCHIVE DESTINATION lib${LIB_SUFFIX}
+                COMPONENT staticlibs
+              )
+    endif ()
+
+    install ( FILES ${cpp_headers}
+              DESTINATION include/${PROJECT_NAME}
+              COMPONENT headers
             )
 
-endif(${WIN32})
+  else ()
+    message(STATUS "Boost not found, won't build libftdi1++")
+  endif ()
 
-else(Boost_FOUND)
-   message(STATUS "Boost not found, won't build libftdi++")
-endif(Boost_FOUND)
+else ()
+  message(STATUS "Not building libftdi1++")
+endif ()