Reformat example code to match libftdi style:
[libftdi] / examples / Makefile.am
index ce82a62..f45c7e5 100644 (file)
@@ -1,13 +1,29 @@
 METASOURCES = AUTO
-INCLUDES = -I$(top_srcdir)/src
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/ftdipp
 LDADD = $(top_builddir)/src/libftdi.la
 
-bin_PROGRAMS = simple \
+
+if HAVE_LIBFTDIPP
+examples_libftdipp = find_all_pp
+else
+examples_libftdipp =
+endif
+
+
+if BUILD_EXAMPLES
+all_examples = simple \
        bitbang       \
        bitbang2      \
        bitbang_ft2232 \
        bitbang_cbus \
-       find_all
+       find_all \
+       serial_read \
+       baud_test \
+       $(examples_libftdipp)
+else
+all_examples =
+endif
+bin_PROGRAMS = $(all_examples)
 
 # Don't install the example files
 AM_LDFLAGS = -no-install
@@ -18,3 +34,12 @@ bitbang2_SOURCES = bitbang2.c
 bitbang_ft2232_SOURCES = bitbang_ft2232.c
 bitbang_cbus_SOURCES = bitbang_cbus.c
 find_all_SOURCES = find_all.c
+serial_read_SOURCES = serial_read.c
+baud_test_SOURCES = baud_test.c
+
+if HAVE_LIBFTDIPP
+find_all_pp_SOURCES = find_all_pp.cpp
+find_all_pp_LDADD = $(top_builddir)/ftdipp/libftdipp.la $(LDADD)
+endif
+
+EXTRA_DIST = CMakeLists.txt