Reformat example code to match libftdi style:
[libftdi] / examples / Makefile.am
index bcd50ec..f45c7e5 100644 (file)
@@ -10,13 +10,20 @@ examples_libftdipp =
 endif
 
 
-bin_PROGRAMS = simple \
+if BUILD_EXAMPLES
+all_examples = simple \
        bitbang       \
        bitbang2      \
        bitbang_ft2232 \
        bitbang_cbus \
        find_all \
+       serial_read \
+       baud_test \
        $(examples_libftdipp)
+else
+all_examples =
+endif
+bin_PROGRAMS = $(all_examples)
 
 # Don't install the example files
 AM_LDFLAGS = -no-install
@@ -27,6 +34,8 @@ bitbang2_SOURCES = bitbang2.c
 bitbang_ft2232_SOURCES = bitbang_ft2232.c
 bitbang_cbus_SOURCES = bitbang_cbus.c
 find_all_SOURCES = find_all.c
+serial_read_SOURCES = serial_read.c
+baud_test_SOURCES = baud_test.c
 
 if HAVE_LIBFTDIPP
 find_all_pp_SOURCES = find_all_pp.cpp