Fix more occurences of serial_read -> serial_test
[libftdi] / examples / Makefile.am
index 820599a..a7d28e2 100644 (file)
@@ -10,15 +10,20 @@ examples_libftdipp =
 endif
 
 
-bin_PROGRAMS = simple \
+if BUILD_EXAMPLES
+all_examples = simple \
        bitbang       \
        bitbang2      \
        bitbang_ft2232 \
        bitbang_cbus \
        find_all \
-       serial_read \
+       serial_test \
        baud_test \
        $(examples_libftdipp)
+else
+all_examples =
+endif
+bin_PROGRAMS = $(all_examples)
 
 # Don't install the example files
 AM_LDFLAGS = -no-install
@@ -29,7 +34,7 @@ bitbang2_SOURCES = bitbang2.c
 bitbang_ft2232_SOURCES = bitbang_ft2232.c
 bitbang_cbus_SOURCES = bitbang_cbus.c
 find_all_SOURCES = find_all.c
-serial_read_SOURCES = serial_read.c
+serial_test_SOURCES = serial_test.c
 baud_test_SOURCES = baud_test.c
 
 if HAVE_LIBFTDIPP