add baud_test example program: compare expected and actual transfer speeds for differ...
[libftdi] / examples / Makefile.am
index bd57253..820599a 100644 (file)
@@ -4,8 +4,7 @@ LDADD = $(top_builddir)/src/libftdi.la
 
 
 if HAVE_LIBFTDIPP
-examples_libftdipp = find_all_pp \
-       memorytest
+examples_libftdipp = find_all_pp
 else
 examples_libftdipp =
 endif
@@ -17,6 +16,8 @@ bin_PROGRAMS = simple \
        bitbang_ft2232 \
        bitbang_cbus \
        find_all \
+       serial_read \
+       baud_test \
        $(examples_libftdipp)
 
 # Don't install the example files
@@ -28,10 +29,12 @@ bitbang2_SOURCES = bitbang2.c
 bitbang_ft2232_SOURCES = bitbang_ft2232.c
 bitbang_cbus_SOURCES = bitbang_cbus.c
 find_all_SOURCES = find_all.c
+serial_read_SOURCES = serial_read.c
+baud_test_SOURCES = baud_test.c
 
 if HAVE_LIBFTDIPP
 find_all_pp_SOURCES = find_all_pp.cpp
 find_all_pp_LDADD = $(top_builddir)/ftdipp/libftdipp.la $(LDADD)
-memorytest_SOURCES = memorytest.cpp
-memorytest_LDADD = $(top_builddir)/ftdipp/libftdipp.la $(LDADD)
 endif
+
+EXTRA_DIST = CMakeLists.txt