Remove api doc headers
[pyi2ncommon] / pyi2ncommon.spec
1 Name:           pyi2ncommon
2 Version:        1.7.0
3 # note: keep version in sync with setup.py
4 Release:        1%{?dist}
5 Summary:        Intra2net library of common helper utilities
6 Group:          Development/Languages
7 License:        Intra2net AG
8 URL:            http://www.intra2net.com
9 Source0:        %{name}-%{version}.tar.gz
10
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13 BuildRequires:  python3-devel
14 BuildRequires:  python3-setuptools
15
16 %description
17 Python interface to some internal workings of Intra2net systems plus internal helpers
18
19 %package -n python3-%{name}
20 Summary:        Intra2net library of common helper utilities
21 Group:          Development/Languages
22 %description -n python3-%{name}
23 Python interface to some internal workings of Intra2net systems plus internal helpers
24
25 %prep
26 %setup -q
27
28 if [ -n "%{patches}" ]; then
29     # Use git to apply patches, so that permission changes work
30     git init
31     # Setup a committer
32     if [ -z "$GIT_COMMITTER_NAME" ]; then
33         git config user.email "opensource@intra2net.com"
34         git config user.name "Intra2net Automatic Patch Applicator"
35     fi
36     git add .
37     git commit --no-gpg-sign -a -q -m 'Initial commit for %{version}'
38     git am -p1 %{patches}
39 fi
40
41 %build
42 %py3_build
43
44 %check
45 ln -s src pyi2ncommon    # make src importable from current dir
46 PYTHONPATH=.:$PYTHONPATH python3 -m unittest discover test
47
48 %install
49 %py3_install
50
51 %files -n python3-%{name}
52 # keep in sync with list in make_dist.py
53 %defattr(-,root,root,-)
54 %license COPYING.GPL
55 %license Linking-Exception.txt
56 %doc README
57 %doc CONTRIBUTING
58 %doc doc/conf.py
59 %doc doc/about_docu.rst
60 %{python3_sitelib}/%{name}
61 %{python3_sitelib}/%{name}-*.egg-info