made nicer static variables of packet dump mode and location
[pingcheck] / pingcheck.spec
1 Summary:   Pingcheck
2 Name:      pingcheck
3 Version:   ##VERSION##
4 Release:   1
5 License:   GPLv2 + linking exception. Some parts under boost license.
6 Group:     Intranator
7 Vendor:    Intra2net AG
8 Source:    %{name}-%{version}.tar.gz
9 Prefix:    /usr/intranator
10 BuildRoot: %{_tmppath}/%{name}-%{version}
11 BuildRequires: cmake
12
13 %define _prefix %{prefix}
14
15 %description
16 Pingcheck
17
18
19 %prep
20 %setup -q
21
22
23 %build
24 export PKG_CONFIG_PATH=/usr/intranator/lib/pkgconfig
25
26 mkdir build
27 cd build
28
29 export CFLAGS="$RPM_OPT_FLAGS"
30 export CXXFLAGS="$RPM_OPT_FLAGS"
31 cmake -DCMAKE_INSTALL_PREFIX="%{prefix}" ../
32
33 make %{_smp_mflags}
34
35 %check
36 #make check
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 cd build
42 make DESTDIR=$RPM_BUILD_ROOT install
43
44
45 %clean
46 rm -fr $RPM_BUILD_ROOT
47
48
49 %files
50 %defattr(-,root,root)
51 %doc LICENSE_1_0.txt COPYING.GPL Readme Readme.code TODO
52 %{_bindir}/pingcheck