libt2n: (gerd) some refactoring, documentation improvement
[libt2n] / src / Makefile.am
index 2b91e29..669ce22 100644 (file)
@@ -3,10 +3,17 @@ INCLUDES= $(all_includes)
 
 # the library search path.
 lib_LTLIBRARIES = libt2n.la
-libt2n_la_SOURCES = server.cpp socket_server.cpp client.cpp connection.cpp \
-       socket_handler.cpp socket_client.cpp command_server.cpp command_client.cpp \
-       t2n_exception.cpp command.cpp container.cpp
+libt2n_la_SOURCES = client.cpp command.cpp command_client.cpp \
+       command_server.cpp connection.cpp container.cpp server.cpp socket_client.cpp \
+       socket_handler.cpp socket_server.cpp t2n_exception.cpp client_wrapper.cpp
+
+# Note:  If you specify a:b:c as the version in the next line,
+#  the library that is made has version (a-c).c.b.  In this
+#  example, the version is 2.1.2. (3:2:1)
+libt2n_la_LDFLAGS = -version-info 1:0:0
+
+pkginclude_HEADERS = client.hxx client_wrapper.hxx command.hxx \
+       command_client.hxx command_server.hxx connection.hxx container.hxx log.hxx server.hxx \
+       socket_client.hxx socket_handler.hxx socket_server.hxx t2n_exception.hxx types.hxx \
+       wrapper_handler_socket.hxx
 
-pkginclude_HEADERS = server.hxx socket_server.hxx t2n_exception.hxx client.hxx \
-                       socket_client.hxx connection.hxx types.hxx socket_handler.hxx command.hxx container.hxx \
-               command_client.hxx command_server.hxx log.hxx