use pkgincludedir for headers (to avoid file name collisions), renamed LIBT2N_CLIENT_...
[libt2n] / src / Makefile.am
index 5dcf1ea..0211215 100644 (file)
@@ -1,10 +1,13 @@
-
 # set the include path found by configure
 INCLUDES= $(all_includes)
 
 # the library search path.
 lib_LTLIBRARIES = libt2n.la
 libt2n_la_LDFLAGS = -module
-libt2n_la_SOURCES = server.cpp socket_server.cpp
+libt2n_la_SOURCES = server.cpp socket_server.cpp client.cpp connection.cpp \
+       socket_handler.cpp socket_client.cpp command_server.cpp command_client.cpp \
+       t2n_exception.cpp command.cpp container.cpp
 
-include_HEADERS = server.hxx socket_server.hxx t2n_exception.hxx
+pkginclude_HEADERS = server.hxx socket_server.hxx t2n_exception.hxx client.hxx \
+                       socket_client.hxx connection.hxx types.hxx socket_handler.hxx command.hxx container.hxx \
+               command_client.hxx command_server.hxx log.hxx