libt2n: (gerd) refactored connection classes
[libt2n] / src / Makefile.am
index 5dcf1ea..e410013 100644 (file)
@@ -5,6 +5,8 @@ INCLUDES= $(all_includes)
 # the library search path.
 lib_LTLIBRARIES = libt2n.la
 libt2n_la_LDFLAGS = -module
-libt2n_la_SOURCES = server.cpp socket_server.cpp
+libt2n_la_SOURCES = server.cpp socket_server.cpp client.cpp connection.cpp \
+       socket_handler.cpp
 
-include_HEADERS = server.hxx socket_server.hxx t2n_exception.hxx
+include_HEADERS = server.hxx socket_server.hxx t2n_exception.hxx client.hxx \
+       socket_client.hxx connection.hxx types.hxx socket_handler.hxx