Cleansed all directories from autohell corruption. Some additional unnecessary files...
[libt2n] / examples-codegen / example2 / Makefile.am
diff --git a/examples-codegen/example2/Makefile.am b/examples-codegen/example2/Makefile.am
deleted file mode 100644 (file)
index 44752ac..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# not a GNU package. You can remove this line, if
-# you have all needed files, that a GNU package needs
-AUTOMAKE_OPTIONS = foreign
-
-INCLUDES = @LIBT2N_CFLAGS@
-LDADD = @LIBT2N_LIBS@
-
-# list your command groups
-CMDGROUPS = default other
-
-# for each command group list the files to parse for LIBT2N_EXPORT
-default_GROUP = default.cpp
-# example of a command group using multiple cpp files
-other_GROUP = other-1.cpp other-2.cpp
-
-# headers declaring data types used as rpc arguments must be listed manually
-# (in this example the class Foo)
-include_HEADERS = foo.hxx
-
-# unfortunately we can't set those from variables
-# because they are parsed by automake
-
-# we would like to use nodist_ here but our automake is to old
-# nodist_libdefault_la_SOURCES = default_client.cpp
-# nodist_libother_la_SOURCES = other_client.cpp
-
-# using objects as workaround for missing nodist_ didn't work
-# libdefault_la_OBJECTS += default_client.lo
-# libother_la_OBJECTS += other_client.lo
-# Note: the library name must match the group name
-
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
-lib_LTLIBRARIES = libdefault.la libother.la
-
-# build an example server and client
-client_SOURCES = client.cpp
-client_LDADD = $(LDADD) libdefault.la libother.la
-
-noinst_PROGRAMS = client
-
-bin_PROGRAMS = libt2n-example2-server
-
-# we would like to use nodist_ here but our automake is to old
-# nodist_server_SOURCES = other_server.cpp default_server.cpp
-# using LDADD as workaround didn't work
-# server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
-
-libt2n_example2_server_SOURCES = \
-       server.cpp $(other_GROUP) $(default_GROUP) \
-       other_server.cpp default_server.cpp
-
-# test script
-
-TESTS = test
-
-EXTRA_DIST = $(TESTS)
-
-# Make libt2n-gccxml.sh available
-# as libt2n is not installed yet
-PATH := $(top_srcdir):$(PATH)
-
-# if you use libt2n-codegen you should add this
-# (i did not find a nice way to let libt2n install this makefile snippet
-# and let projects using libt2n use the installed version.
-# the core of the problem is:
-# the makefile snippet is already needed when automake is run
-# => no way to let configure locate the snippet)
-include codegen.make