Small corrections. Compiles and builds.
[libt2n] / examples-codegen / example1-client-wrapper / CMakeLists.txt
index dbd8e91..b54f1ab 100644 (file)
@@ -13,13 +13,13 @@ set(CPACK_SOURCE_IGNORE_FILES          "~$;\\\\.git;build;build-rpm")
 set(CPACK_SOURCE_PACKAGE_FILE_NAME     "${PROJECT_NAME}-${VERSION}")
 
 # Find external packages
-include(FindPkgConfig)
+# include(FindPkgConfig)
 
-pkg_check_modules(T2NEXAMPLE REQUIRED t2nexample=0.1)
-include_directories(${T2NEXAMPLE_INCLUDE_DIRS})
-link_directories(${T2NEXAMPLE_LIBRARY_DIRS})
+# pkg_check_modules(T2NEXAMPLE REQUIRED t2nexample=0.1)
+# include_directories(${T2NEXAMPLE_INCLUDE_DIRS})
+# link_directories(${T2NEXAMPLE_LIBRARY_DIRS})
 
-include(CPack)
+# include(CPack)
 
 # Sources
 set(libt2n_example1_client_wrapper_SOURCES
@@ -30,7 +30,8 @@ set(libt2n_example1_client_wrapper_SOURCES
 add_executable(libt2n-example1-client-wrapper ${libt2n_example1_client_wrapper_SOURCES})
 
 # Dependencies
-target_link_libraries(libt2n-example1-client-wrapper ${T2NEXAMPLE_LIBRARIES})
+# target_link_libraries(libt2n-example1-client-wrapper ${T2NEXAMPLE_LIBRARIES})
+target_link_libraries(libt2n-example1-client-wrapper t2nexample)
 
 # Installation
 # install(TARGETS libt2n-example1-client-wrapper DESTINATION bin)