put include dependencies into seperate file (one file per command group). simplifies...
[libt2n] / example-codegen / Makefile.am
index d4dae59..db45e0c 100644 (file)
@@ -45,7 +45,7 @@ GROUPDEP_FILES =  $(foreach i, $(CMDGROUPS), .deps/group_$(i).P)
        for i in $($*_GROUP); do \
                gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
        done; \
-       $(top_builddir)/codegen/codegen $*.cpp $* $($*_GROUP:.cpp=.xml) && touch $@
+       $(top_builddir)/codegen/codegen $* $($*_GROUP:.cpp=.xml) && touch $@
 
 # assuming we have gnu make?
 BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp _client.hxx _client.cpp _server.hxx _server.cpp, $(i)$(j)) )