unfortunately dist-hook only works if directly visible for automake
[libt2n] / example-codegen / Makefile.am
index 1911f20..cabf100 100644 (file)
@@ -1,6 +1,3 @@
-# if you use codegen you should add the next line
-@LIBT2N_CODEGEN_MAKESNIPPET@
-
 INCLUDES = @LIBT2N_CPPFLAGS@
 LDADD = @LIBT2N_LIBS@
 
@@ -39,4 +36,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
+
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
+
+# if you use codegen you should add the next line at the end
+@LIBT2N_CODEGEN_MAKESNIPPET@