(no commit message)
[libt2n] / example-codegen / Makefile.am
index d1134fe..b2c51de 100644 (file)
@@ -1,5 +1,9 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
 # list your command groups
 CMDGROUPS = default other
@@ -36,6 +40,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
 
-include $(top_srcdir)/codegen/codegen.make
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make