CLEANFILES must be listed directly, too - otherwise automake will not use it :-(
[libt2n] / example-codegen / Makefile.am
index d1134fe..a4195d4 100644 (file)
@@ -1,5 +1,9 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
+
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
 # list your command groups
 CMDGROUPS = default other
@@ -36,6 +40,15 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
+
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(LIBT2N_CODEGEN_BUILT), $(distdir)/$(i))
+
+# if you use libt2n-codegen you should add this
+@LIBT2N_CODEGEN_MAKESNIPPET@
+
+CLEANFILES = $(LIBT2N_SUGGESTED_CLEANFILES)
 
-include $(top_srcdir)/codegen/codegen.make