CLEANFILES must be listed directly, too - otherwise automake will not use it :-(
[libt2n] / example-codegen / Makefile.am
index ca49cb8..a4195d4 100644 (file)
@@ -1,3 +1,7 @@
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
+
 INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
 
@@ -41,7 +45,10 @@ EXTRA_DIST = $(TESTS) configure.in
 # we have got an old automake version (1.4-p5) which doesn't support nodist_
 # => you might want to use the dist-hook to remove generated files
 dist-hook:
-       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
+       rm -vf $(foreach i, $(LIBT2N_CODEGEN_BUILT), $(distdir)/$(i))
 
-# if you use codegen you should add the next line at the end
+# if you use libt2n-codegen you should add this
 @LIBT2N_CODEGEN_MAKESNIPPET@
+
+CLEANFILES = $(LIBT2N_SUGGESTED_CLEANFILES)
+