CLEANFILES must be listed directly, too - otherwise automake will not use it :-(
[libt2n] / example-codegen / Makefile.am
index 1037dab..a4195d4 100644 (file)
@@ -1,77 +1,54 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
 
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
+
+# list your command groups
 CMDGROUPS = default other
 
+# for each command group list the files to parse for LIBT2N_EXPORT
 default_GROUP = default.cpp
-# command example of group using multiple cpp files
+# example of a command group using multiple cpp files
 other_GROUP = other-1.cpp other-2.cpp
 
-# foo.hxx must be listed manually
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
 include_HEADERS = foo.hxx
 
 # unfortunately we can't set those from variables
 # because they are parsed by automake
+# and we can't use noinst since our automake version is to old
+# (see dist-hook in codegen.make)
 
 libdefault_la_SOURCES = default_client.cpp
 libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
-
 # build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
-server_SOURCES = server.cpp \
-       $(other_GROUP) other_server.cpp \
-       $(default_GROUP) default_server.cpp \
-       foo.hxx
+
 noinst_PROGRAMS = client server
 
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP) \
+       other_server.cpp default_server.cpp
+
 # test script
 
 TESTS = test
 
-# always the same:
-
-include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
-
-#IFILES=$(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j)))
-
--include $(foreach i, $(CMDGROUPS), .deps/group_$(i).P)
-
-.deps/group_%.P : Makefile.am
-       echo $@ : $($*_GROUP) > .deps/group_$*.P
-
-%.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
-# assuming we have some unix like shell (maybe even bash)
-       echo BUILT_SOURCES: $(BUILT_SOURCES)
-       cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $*_common.hxx;
-       echo > $*_server.hxx;
-# todo use tmp file for xml file
-       for i in $($*_GROUP); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
-       done; \
-       $(top_builddir)/codegen/codegen $* $($*_GROUP:.cpp=.xml) && touch $@
-
-# assuming we have gnu make?
-BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp _client.hxx _client.cpp _server.hxx _server.cpp, $(i)$(j)) )
-
-STAMPS=$(CMDGROUPS:=.stamp)
-$(BUILT_SOURCES) : $(STAMPS)
+EXTRA_DIST = $(TESTS) configure.in
 
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(LIBT2N_CODEGEN_BUILT), $(distdir)/$(i))
 
-CLEANFILES = $(BUILT_SOURCES) $(STAMPS)
+# if you use libt2n-codegen you should add this
+@LIBT2N_CODEGEN_MAKESNIPPET@
 
-# Install the pkg-config files:
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = $(CMDGROUPS:=.pc)
+CLEANFILES = $(LIBT2N_SUGGESTED_CLEANFILES)
 
-# .pc files (one pc file for each command group)
-%.pc : $(top_srcdir)/codegen/clientlib.pc.in Makefile
-       sed \
-       -e 's,@CMDGROUP@,$*,g' \
-       -e 's,\@prefix\@,$(prefix),g' \
-       -e 's,\@exec_prefix\@,$(exec_prefix),g' \
-       -e 's,\@libdir\@,$(libdir),g' \
-       -e 's,\@includedir\@,$(includedir),g' \
-       $< >$*.pc