make distcheck fixes
[libt2n] / example-codegen / Makefile.am
index d2e5931..816fafd 100644 (file)
@@ -34,8 +34,7 @@ noinst_PROGRAMS = client server
 
 TESTS = test
 
-
-
+EXTRA_DIST = $(TESTS)
 
 # always the same:
 
@@ -43,20 +42,20 @@ include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
 
 #IFILES=$(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j)))
 
--include $(foreach i, $(CMDGROUPS), .deps/group_$(i).P)
+-include $(foreach i, $(CMDGROUPS), group_$(i).P)
 
-.deps/group_%.P : Makefile.am
-       echo $@ : $($*_GROUP) > .deps/group_$*.P
+group_%.P : Makefile.am
+       echo $@ : $($*_GROUP) > group_$*.P
 
-%.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
+%.stamp : group_%.P $(top_builddir)/codegen/codegen
 # assuming we have some unix like shell (maybe even bash)
        echo BUILT_SOURCES: $(BUILT_SOURCES)
+# temporarily create _common.hxx file (will be overwritten by codegen below)
        echo '#include "codegen-stubhead.hxx"' > $*_common.hxx;
        echo '#include "$*.hxx"' >> $*_common.hxx;
-       echo > $*_server.hxx;
 # todo use tmp file for xml file
        for i in $($*_GROUP); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
+               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $(srcdir)/$${i} -fxml=$${i%*.cpp}.xml; \
        done; \
        $(top_builddir)/codegen/codegen $* $($*_GROUP:.cpp=.xml) && touch $@