explicitely list dependencies to fix parallel first time builds
[libt2n] / example-codegen / Makefile.am
index b11e881..3d710d5 100644 (file)
@@ -9,7 +9,13 @@ noinst_LTLIBRARIES = libdefault.la libother.la
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp other_server.cpp default_server.cpp other.cpp default.cpp foo.hxx
+client.cpp : default_client.hxx other_client.hxx
+server.cpp : default_client.hxx other_client.hxx
+
+server_SOURCES = server.cpp \
+       other.cpp other_server.cpp \
+       default.cpp default_server.cpp \
+       foo.hxx
 
 noinst_PROGRAMS = client server
 
@@ -25,7 +31,24 @@ codegen.stamp: default.cpp other.cpp $(top_builddir)/codegen/codegen
                $(top_builddir)/codegen/codegen $${i}.cpp $${i}.xml $${i}; \
        done; touch $@
 
-default_common.hxx default_common.cpp default_client.hxx default_client.cpp default_server.hxx default_server.cpp: codegen.stamp
-other_common.hxx other_common.cpp other_client.hxx other_client.cpp other_server.hxx other_server.cpp: codegen.stamp
+DEFAULT_GENERATED = default_common.hxx default_common.cpp default_client.hxx default_client.cpp default_server.hxx default_server.cpp
+$(DEFAULT_GENERATED): codegen.stamp
+
+OTHER_GENERATED = other_common.hxx other_common.cpp other_client.hxx other_client.cpp other_server.hxx other_server.cpp
+$(OTHER_GENERATED): codegen.stamp
 
 TESTS = test
+
+CLEANFILES = $(DEFAULT_GENERATED) $(OTHER_GENERATED) codegen.stamp
+
+# TODO:
+# howto generate Makefile(.in) from something like this:
+
+# CMDGROUPS = default other
+
+# default_SOURCES = default-1.cpp default-2.cpp
+# other_SOURCES = other.cpp
+
+# TESTS = test
+
+# server_SOURCES = server.cpp default foo.hxx