explicitely list dependencies to fix parallel first time builds
[libt2n] / example-codegen / Makefile.am
index 4f80d48..3d710d5 100644 (file)
@@ -2,20 +2,53 @@ INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)
 
 LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
 
-libclient_la_SOURCES = codegen_client.cpp
-noinst_LTLIBRARIES = libclient.la
+libdefault_la_SOURCES = default_client.cpp
+libother_la_SOURCES = other_client.cpp
+noinst_LTLIBRARIES = libdefault.la libother.la
 
 client_SOURCES = client.cpp
-client_LDADD = $(LDADD) libclient.la
+client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp codegen_server.cpp
+client.cpp : default_client.hxx other_client.hxx
+server.cpp : default_client.hxx other_client.hxx
+
+server_SOURCES = server.cpp \
+       other.cpp other_server.cpp \
+       default.cpp default_server.cpp \
+       foo.hxx
 
 noinst_PROGRAMS = client server
 
-codegen.stamp: server.hxx $(top_builddir)/codegen/codegen
-       cp $(top_srcdir)/codegen/codegen-stubhead.hxx codegen_common.hxx
-       gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) server.hxx -fxml=tmpserver.xml
-       $(top_builddir)/codegen/codegen tmpserver.xml codegen_
-       touch codegen.stamp
+codegen.stamp: default.cpp other.cpp $(top_builddir)/codegen/codegen
+# assuming we have some unix like shell
+       for i in default other; do \
+               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_common.hxx; \
+               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_server.hxx; \
+       done
+# todo use tmp file for xml file
+       for i in default other; do \
+               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i}.cpp -fxml=$${i}.xml; \
+               $(top_builddir)/codegen/codegen $${i}.cpp $${i}.xml $${i}; \
+       done; touch $@
+
+DEFAULT_GENERATED = default_common.hxx default_common.cpp default_client.hxx default_client.cpp default_server.hxx default_server.cpp
+$(DEFAULT_GENERATED): codegen.stamp
+
+OTHER_GENERATED = other_common.hxx other_common.cpp other_client.hxx other_client.cpp other_server.hxx other_server.cpp
+$(OTHER_GENERATED): codegen.stamp
+
+TESTS = test
+
+CLEANFILES = $(DEFAULT_GENERATED) $(OTHER_GENERATED) codegen.stamp
+
+# TODO:
+# howto generate Makefile(.in) from something like this:
+
+# CMDGROUPS = default other
+
+# default_SOURCES = default-1.cpp default-2.cpp
+# other_SOURCES = other.cpp
+
+# TESTS = test
 
-codegen_common.hxx codegen_common.cpp codegen_client.hxx codegen_client.cpp codegen_server.cpp: codegen.stamp
+# server_SOURCES = server.cpp default foo.hxx