cleanup
[libt2n] / example-codegen / Makefile.am
index 1037dab..3cc4d3d 100644 (file)
@@ -1,13 +1,16 @@
 INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
 LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
 
+# list your command groups
 CMDGROUPS = default other
 
+# for each command group list the files to parse for LIBT2N_EXPORT
 default_GROUP = default.cpp
-# command example of group using multiple cpp files
+# example of a command group using multiple cpp files
 other_GROUP = other-1.cpp other-2.cpp
 
-# foo.hxx must be listed manually
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
 include_HEADERS = foo.hxx
 
 # unfortunately we can't set those from variables
@@ -17,20 +20,23 @@ libdefault_la_SOURCES = default_client.cpp
 libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
-
 # build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
+
 server_SOURCES = server.cpp \
        $(other_GROUP) other_server.cpp \
-       $(default_GROUP) default_server.cpp \
-       foo.hxx
+       $(default_GROUP) default_server.cpp
+
 noinst_PROGRAMS = client server
 
 # test script
 
 TESTS = test
 
+
+
+
 # always the same:
 
 include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
@@ -45,8 +51,9 @@ include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
 %.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
 # assuming we have some unix like shell (maybe even bash)
        echo BUILT_SOURCES: $(BUILT_SOURCES)
-       cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $*_common.hxx;
-       echo > $*_server.hxx;
+# temporarily create _common.hxx file (will be overwritten by codegen below)
+       echo '#include "codegen-stubhead.hxx"' > $*_common.hxx;
+       echo '#include "$*.hxx"' >> $*_common.hxx;
 # todo use tmp file for xml file
        for i in $($*_GROUP); do \
                gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
@@ -59,9 +66,6 @@ BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp
 STAMPS=$(CMDGROUPS:=.stamp)
 $(BUILT_SOURCES) : $(STAMPS)
 
-
-CLEANFILES = $(BUILT_SOURCES) $(STAMPS)
-
 # Install the pkg-config files:
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = $(CMDGROUPS:=.pc)
@@ -75,3 +79,11 @@ pkgconfig_DATA = $(CMDGROUPS:=.pc)
        -e 's,\@libdir\@,$(libdir),g' \
        -e 's,\@includedir\@,$(includedir),g' \
        $< >$*.pc
+
+CLEANFILES = $(BUILT_SOURCES) $(STAMPS) $(pkgconfig_DATA)
+
+# didn't work (same problem as with _LTLIBRARIES [parsing by automake],
+# this time _OBJECTS was not correct)
+# server_SOURCES = server.cpp \
+#      $(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j))) \
+#      $(foreach i, $(CMDGROUPS), $(i)_server.cpp)