try to find workaround for old automake
[libt2n] / example-codegen / Makefile.am
index d5670f3..00aaac7 100644 (file)
@@ -1,6 +1,6 @@
 # not a GNU package. You can remove this line, if
 # you have all needed files, that a GNU package needs
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign
 
 INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
@@ -19,11 +19,16 @@ include_HEADERS = foo.hxx
 
 # unfortunately we can't set those from variables
 # because they are parsed by automake
-# and we can't use noinst since our automake version is to old
-# (see dist-hook in codegen.make)
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
+# we would like to use nodist_ here but our automake is to old
+# nodist_libdefault_la_SOURCES = default_client.cpp
+# nodist_libother_la_SOURCES = other_client.cpp
+
+# using objects as workaround
+libdefault_la_OBJECTS += default_client.lo
+#libdefault_la_SOURCES = default_client.cpp
+libother_la_OBJECTS += other_client.lo
+#libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
 # build an example server and client
@@ -32,9 +37,15 @@ client_LDADD = $(LDADD) libdefault.la libother.la
 
 noinst_PROGRAMS = client server
 
+# we would like to use nodist_ here but our automake is to old
+# nodist_server_SOURCES = other_server.cpp default_server.cpp
+
+server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
+
 server_SOURCES = \
-       server.cpp $(other_GROUP) $(default_GROUP) \
-       other_server.cpp default_server.cpp
+       server.cpp $(other_GROUP) $(default_GROUP)
+#      other_server.cpp default_server.cpp
+
 
 # test script