try to find workaround for old automake
[libt2n] / example-codegen / Makefile.am
index d2e5931..00aaac7 100644 (file)
@@ -1,5 +1,9 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
 # list your command groups
 CMDGROUPS = default other
@@ -16,74 +20,43 @@ include_HEADERS = foo.hxx
 # unfortunately we can't set those from variables
 # because they are parsed by automake
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
+# we would like to use nodist_ here but our automake is to old
+# nodist_libdefault_la_SOURCES = default_client.cpp
+# nodist_libother_la_SOURCES = other_client.cpp
+
+# using objects as workaround
+libdefault_la_OBJECTS += default_client.lo
+#libdefault_la_SOURCES = default_client.cpp
+libother_la_OBJECTS += other_client.lo
+#libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
 # build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp \
-       $(other_GROUP) other_server.cpp \
-       $(default_GROUP) default_server.cpp
-
 noinst_PROGRAMS = client server
 
-# test script
-
-TESTS = test
-
-
+# we would like to use nodist_ here but our automake is to old
+# nodist_server_SOURCES = other_server.cpp default_server.cpp
 
+server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
 
-# always the same:
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP)
+#      other_server.cpp default_server.cpp
 
-include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
 
-#IFILES=$(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j)))
-
--include $(foreach i, $(CMDGROUPS), .deps/group_$(i).P)
-
-.deps/group_%.P : Makefile.am
-       echo $@ : $($*_GROUP) > .deps/group_$*.P
-
-%.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
-# assuming we have some unix like shell (maybe even bash)
-       echo BUILT_SOURCES: $(BUILT_SOURCES)
-       echo '#include "codegen-stubhead.hxx"' > $*_common.hxx;
-       echo '#include "$*.hxx"' >> $*_common.hxx;
-       echo > $*_server.hxx;
-# todo use tmp file for xml file
-       for i in $($*_GROUP); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
-       done; \
-       $(top_builddir)/codegen/codegen $* $($*_GROUP:.cpp=.xml) && touch $@
-
-# assuming we have gnu make?
-BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp _client.hxx _client.cpp _server.hxx _server.cpp, $(i)$(j)) )
-
-STAMPS=$(CMDGROUPS:=.stamp)
-$(BUILT_SOURCES) : $(STAMPS)
-
-# Install the pkg-config files:
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = $(CMDGROUPS:=.pc)
+# test script
 
-# .pc files (one pc file for each command group)
-%.pc : $(top_srcdir)/codegen/clientlib.pc.in Makefile
-       sed \
-       -e 's,@CMDGROUP@,$*,g' \
-       -e 's,\@prefix\@,$(prefix),g' \
-       -e 's,\@exec_prefix\@,$(exec_prefix),g' \
-       -e 's,\@libdir\@,$(libdir),g' \
-       -e 's,\@includedir\@,$(includedir),g' \
-       $< >$*.pc
+TESTS = test
 
-CLEANFILES = $(BUILT_SOURCES) $(STAMPS) $(pkgconfig_DATA)
+EXTRA_DIST = $(TESTS) configure.in
 
-# didn't work (same problem as with _LTLIBRARIES [parsing by automake],
-# this time _OBJECTS was not correct)
-# server_SOURCES = server.cpp \
-#      $(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j))) \
-#      $(foreach i, $(CMDGROUPS), $(i)_server.cpp)
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make