client lib include must not depend on _common.hxx
[libt2n] / example-codegen / Makefile.am
index 450f1de..d2e5931 100644 (file)
@@ -51,7 +51,8 @@ include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
 %.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
 # assuming we have some unix like shell (maybe even bash)
        echo BUILT_SOURCES: $(BUILT_SOURCES)
-       cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $*_common.hxx;
+       echo '#include "codegen-stubhead.hxx"' > $*_common.hxx;
+       echo '#include "$*.hxx"' >> $*_common.hxx;
        echo > $*_server.hxx;
 # todo use tmp file for xml file
        for i in $($*_GROUP); do \