cleanup
[libt2n] / example-codegen / Makefile.am
index d2e5931..3cc4d3d 100644 (file)
@@ -51,9 +51,9 @@ include_HEADERS += $(foreach i, $(CMDGROUPS), $(i)_client.hxx $(i).hxx)
 %.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen
 # assuming we have some unix like shell (maybe even bash)
        echo BUILT_SOURCES: $(BUILT_SOURCES)
+# temporarily create _common.hxx file (will be overwritten by codegen below)
        echo '#include "codegen-stubhead.hxx"' > $*_common.hxx;
        echo '#include "$*.hxx"' >> $*_common.hxx;
-       echo > $*_server.hxx;
 # todo use tmp file for xml file
        for i in $($*_GROUP); do \
                gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \