added some comments. remove .pc files on make clean
[libt2n] / example-codegen / Makefile.am
index 1037dab..14cd67d 100644 (file)
@@ -1,10 +1,12 @@
 INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
 LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
 
+# list your command groups
 CMDGROUPS = default other
 
+# for each command group list the files to parse for LIBT2N_EXPORT
 default_GROUP = default.cpp
-# command example of group using multiple cpp files
+# example of a command group using multiple cpp files
 other_GROUP = other-1.cpp other-2.cpp
 
 # foo.hxx must be listed manually
@@ -17,14 +19,15 @@ libdefault_la_SOURCES = default_client.cpp
 libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
-
 # build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
+
 server_SOURCES = server.cpp \
        $(other_GROUP) other_server.cpp \
        $(default_GROUP) default_server.cpp \
        foo.hxx
+
 noinst_PROGRAMS = client server
 
 # test script
@@ -59,9 +62,6 @@ BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp
 STAMPS=$(CMDGROUPS:=.stamp)
 $(BUILT_SOURCES) : $(STAMPS)
 
-
-CLEANFILES = $(BUILT_SOURCES) $(STAMPS)
-
 # Install the pkg-config files:
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = $(CMDGROUPS:=.pc)
@@ -75,3 +75,5 @@ pkgconfig_DATA = $(CMDGROUPS:=.pc)
        -e 's,\@libdir\@,$(libdir),g' \
        -e 's,\@includedir\@,$(includedir),g' \
        $< >$*.pc
+
+CLEANFILES = $(BUILT_SOURCES) $(STAMPS) $(pkgconfig_DATA)