doxygen documentation cannot be built using a seperate build directory but we do...
[libt2n] / doc / Makefile.am
index 0c2cbcf..c1297fe 100644 (file)
@@ -10,6 +10,6 @@ all: $(MANUALS)
 
 # todo: separate build dir still doesn't work
 html/index.html: $(top_srcdir)/src/*.cpp $(top_srcdir)/src/*.hxx $(top_srcdir)/codegen/*.hxx $(top_srcdir)/codegen/*.cpp $(srcdir)/index.doc
-       if [ "$srcdir" = "$builddir" ]; then $(DOXYGEN); else echo "FIXME: doxygen documentation cannot be built using a seperate build directory"; fi
+       if test -f header.html; then $(DOXYGEN); else echo "FIXME: doxygen documentation cannot be built using a seperate build directory"; fi
 
 EXTRA_DIST = index.doc header.html