rename codegen binary to libt2n-codegen, prepare makefile snippet for installation...
[libt2n] / codegen / Makefile.am
index f156c98..b5689df 100644 (file)
@@ -1,11 +1,11 @@
-INCLUDES = @CODEGEN_CFLAGS@
-LDADD = @CODEGEN_LIBS@
+INCLUDES = @XMLPP_CFLAGS@
+LDADD = @XMLPP_LIBS@
 
-codegen_SOURCES = main.cpp
+libt2n_codegen_SOURCES = main.cpp
 
-bin_PROGRAMS = codegen
+bin_PROGRAMS = libt2n-codegen
 
-EXTRA_DIST = clientlib.pc.in
+EXTRA_DIST = clientlib.pc.in codegen.make
 
 # todo: do we really want to install it
 # (maybe it would be better to install a copy with each client lib?)