allow to change mapping of group to classname easily
[libt2n] / codegen / Makefile.am
index f156c98..998b67b 100644 (file)
@@ -1,12 +1,17 @@
-INCLUDES = @CODEGEN_CFLAGS@
-LDADD = @CODEGEN_LIBS@
+INCLUDES = @XMLPP_CFLAGS@
+LDADD = @XMLPP_LIBS@
 
-codegen_SOURCES = main.cpp
+libt2n_codegen_SOURCES = main.cpp
 
-bin_PROGRAMS = codegen
+bin_PROGRAMS = libt2n-codegen
 
-EXTRA_DIST = clientlib.pc.in
+pkgdata_DATA = clientlib.pc.in
 
-# todo: do we really want to install it
-# (maybe it would be better to install a copy with each client lib?)
-include_HEADERS = codegen-stubhead.hxx
+# needed because we use old automake not supporting dist_ prefix
+
+EXTRA_DIST = $(pkgdata_DATA)
+
+# do we really want to install it?
+# maybe it would be better to install a copy with each client lib or let codegen insert the code?
+# on the other hand the generated libraries depend on the libt2n headers anyway
+pkginclude_HEADERS = codegen-stubhead.hxx