install makefile snippet and .pc file template
[libt2n] / codegen / Makefile.am
index 1f3846a..2463620 100644 (file)
@@ -1,6 +1,16 @@
-INCLUDES = @CODEGEN_CFLAGS@
-LDADD = @CODEGEN_LIBS@
+INCLUDES = @XMLPP_CFLAGS@
+LDADD = @XMLPP_LIBS@
 
-codegen_SOURCES = main.cpp
+libt2n_codegen_SOURCES = main.cpp
 
-bin_PROGRAMS = codegen
+bin_PROGRAMS = libt2n-codegen
+
+pkgdata_DATA = clientlib.pc.in codegen.make
+
+# needed because we use old automake not supporting dist_ prefix
+
+EXTRA_DIST = $(pkgdata_DATA)
+
+# todo: do we really want to install it
+# (maybe it would be better to install a copy with each client lib?)
+include_HEADERS = codegen-stubhead.hxx