update ideas / todo
[libasyncio] / libsimpleio.spec
1 Summary:   library with asynchronous io functionality for Intra2net programs
2 Name:      libsimpleio
3 Version:   ##VERSION##
4 Release:   1
5 License:   Intranator License
6 Group:     Intranator
7 Vendor:    Intra2net AG
8 Source:    %{name}-%{version}.tar.gz
9 Buildroot: /tmp/%{name}-%{version}-root
10 Prefix:    /usr/intranator
11 Requires:  libi2ncommon >= 1.0
12 Requires:   boost >= 1.32.0
13 BuildPrereq: libtool
14 BuildRequires: boost-devel >= 1.32.0
15 BuildRequires: libt2n-devel >= 0.4
16
17
18 %description 
19 library with asynchronous io functionality for Intra2net programs.
20
21
22 %package   devel
23 Summary:   library with asynchronous io functionality for Intra2net programs
24 Group:     Intranator/Development
25 Requires:  libi2ncommon-devel
26 Requires: boost-devel >= 1.32.0
27
28
29 %description devel
30 development files for library with asynchronous io functionality for Intra2net programs
31
32
33 %package t2n
34 Summary:    glue library for using t2n with libsimpleio
35 Group:      Intranator
36 Requires:   libt2n >= 0.4
37
38 %description t2n
39 glue lib for using t2n with simpleio.
40
41
42 %package t2n-devel
43 Summary:    glue library for using t2n with libsimpleio
44 Group:      Intranator/Development
45 Requires:   libt2n-devel >= 0.4
46
47 %description t2n-devel
48 development files for glue lib for using t2n with simpleio.
49
50
51
52 %prep
53 %setup -q
54
55 %build
56 export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/intranator/lib/pkgconfig
57 autoreconf --force -i
58 ./configure $RPM_BUILD_WITH_OPTIMIZE --prefix=%{prefix}
59 dmake
60
61 dmake check
62
63 %install
64 make DESTDIR=$RPM_BUILD_ROOT install
65
66 %clean
67 rm -fr $RPM_BUILD_ROOT
68
69 %post
70 /sbin/ldconfig
71
72 %files
73 %defattr(-,root,root)
74 %doc LICENSE
75 %{prefix}/lib/libsimpleio.so*
76
77 %files devel
78 %defattr(-,root,root)
79 %{prefix}/lib/libsimpleio.*a*
80 %{prefix}/lib/pkgconfig/libsimpleio.pc
81 %{prefix}/include/simpleio.hpp
82 %{prefix}/include/simple[a-hj-z]*.hpp
83
84 %files t2n
85 %defattr(-,root,root)
86 %doc LICENSE
87 %{prefix}/lib/libsimpleio_t2n.so*
88
89 %files t2n-devel
90 %defattr(-,root,root)
91 %{prefix}/lib/libsimpleio_t2n.*a*
92 %{prefix}/lib/pkgconfig/libsimpleio_t2n.pc
93 %{prefix}/include/simpleio_t2n*.hpp
94