log_read: correct error message
[pyi2ncommon] / pyi2ncommon.spec
CommitLineData
ac74ff48 1Name: pyi2ncommon
4a8e1f27 2Version: 1.6.6
ac74ff48
CH
3# note: keep version in sync with setup.py
4Release: 1%{?dist}
5Summary: Intra2net library of common helper utilities
6Group: Development/Languages
7License: Intra2net AG
8URL: http://www.intra2net.com
9Source0: %{name}-%{version}.tar.gz
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12BuildArch: noarch
13BuildRequires: python3-devel
14BuildRequires: python3-setuptools
15
16%description
17Helper modules for Intra2net source code that are used in several places and/or are of general interest
18
19%package -n python3-%{name}
20Summary: Intra2net library of common helper utilities
21Group: Development/Languages
22%description -n python3-%{name}
23Helper modules for Intra2net source code that are used in several places and/or are of general interest
24
25%prep
26%setup -q
27
28if [ -n "%{patches}" ]; then
29 # Use git to apply patches, so that permission changes work
30 git init
31 # Setup a committer
32 if [ -z "$GIT_COMMITTER_NAME" ]; then
33 git config user.email "opensource@intra2net.com"
34 git config user.name "Intra2net Automatic Patch Applicator"
35 fi
36 git add .
37 git commit --no-gpg-sign -a -q -m 'Initial commit for %{version}'
38 git am -p1 %{patches}
39fi
40
41%build
42%py3_build
43
44%check
45ln -s src pyi2ncommon # make src importable from current dir
46PYTHONPATH=.:$PYTHONPATH python3 -m unittest discover test
47
48%install
49%py3_install
50
51%files -n python3-%{name}
52# keep in sync with list in make_dist.py
53%defattr(-,root,root,-)
54%license COPYING.GPL
55%license Linking-Exception.txt
56%doc README
57%doc CONTRIBUTING
58%doc doc/conf.py
59%doc doc/about_docu.rst
60%{python3_sitelib}/%{name}
61%{python3_sitelib}/%{name}-*.egg-info