Add GPLv2 + linking exception to the source
[pingcheck] / pingcheck.spec
CommitLineData
4fcbbcf1 1Summary: Pingcheck
aca0d1d7 2Name: pingcheck
4fcbbcf1
GMF
3Version: ##VERSION##
4Release: 1
5License: Intranator License
6Group: Intranator
7Vendor: Intra2net AG
8Source: %{name}-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}
10BuildRequires: cmake
11
12
13%description
14Pingcheck
15
16
17%prep
18%setup -q
19
20
21%build
22export PKG_CONFIG_PATH=/usr/intranator/lib/pkgconfig
23
24mkdir build
25cd build
26
27export CFLAGS="$RPM_OPT_FLAGS"
28export CXXFLAGS="$RPM_OPT_FLAGS"
29cmake -DCMAKE_INSTALL_PREFIX="%{_prefix}" ../
30
26eb9632 31make %{_smp_mflags}
4fcbbcf1 32
26eb9632 33%check
4fcbbcf1
GMF
34#make check
35
4fcbbcf1
GMF
36%install
37rm -rf $RPM_BUILD_ROOT
38
39cd build
40make DESTDIR=$RPM_BUILD_ROOT install
41
42
43%clean
44rm -fr $RPM_BUILD_ROOT
45
46
47%files
48%defattr(-,root,root)
7f023582 49%doc LICENSE
aca0d1d7 50%{_bindir}/pingcheck