Add new base64_encode() / base64_decode() functions
[libi2ncommon] / src / CMakeLists.txt
index 7d4c5fc..e9fe706 100644 (file)
@@ -58,7 +58,11 @@ SET(cpp_headers
 
 add_library(i2ncommon SHARED ${cpp_sources} ${cpp_headers})
 
-target_link_libraries(i2ncommon ${Boost_IOSTREAMS_LIBRARIES} ${Boost_THREAD_LIBRARIES} ${ICONV_LIBRARIES})
+target_link_libraries(i2ncommon
+                      ${Boost_IOSTREAMS_LIBRARIES}
+                      ${Boost_THREAD_LIBRARIES}
+                      ${ICONV_LIBRARIES}
+                      ${OPENSSL_LIBRARIES})
 
 set_target_properties(i2ncommon PROPERTIES VERSION ${VERSION} SOVERSION 6)