Merge remote-tracking branch 'origin/cmake-conversion'
[libasyncio] / utils / Makefile.am
diff --git a/utils/Makefile.am b/utils/Makefile.am
deleted file mode 100644 (file)
index a9f81d7..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-AUTOMAKEOPTIONS = foreign 1.4
-
-INCLUDES = @BOOST_CPPFLAGS@
-METASOURCES = AUTO
-
-lib_LTLIBRARIES = libasyncio_utils.la
-
-if HAVE_LIBI2NCOMMON
-compat_headers=
-compat_sources=
-else
-compat_headers= i2ncommon/containerfunc.hpp i2ncommon/signalfunc.hpp
-compat_sources= i2ncommon/containerfunc.cpp i2ncommon/signalfunc.cpp
-endif
-
-include_HEADERS = asyncio_ptr_list.hpp asyncio_utils.hpp asyncio_time_tools.hpp \
-       asyncio_pointer_func.hpp asyncio_system_tools.hpp \
-       asyncio_containerfunc.hpp asyncio_signalfunc.hpp \
-       $(compat_headers)
-libasyncio_utils_la_SOURCES = asyncio_time_tools.cpp asyncio_utils.cpp \
-       asyncio_system_tools.cpp \
-       $(compat_sources)
-
-libasyncio_utils_la_LDFLAGS = -version-info @LIBASYNCIO_LIB_VERSION@
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA= libasyncio_utils.pc
-
-
-$(top_srcdir)/headerlist.utils: $(include_HEADERS)
-       list='$(include_HEADERS)'; \
-       ( for n in $$list; do echo $(includedir)/$$n ; done) > $@
-
-.PHONY: headerlist
-headerlist: $(top_srcdir)/headerlist.utils