Added checking for header files in order to get proper define directives in the confi...
[libasyncio] / asyncio / CMakeLists.txt
index 4d16a7f..8a1521d 100644 (file)
@@ -28,7 +28,7 @@ set_target_properties(libasyncio PROPERTIES VERSION ${VERSION} SOVERSION 0)
 set_target_properties(libasyncio PROPERTIES OUTPUT_NAME asyncio)
 
 # Dependencies
-target_link_libraries(libasyncio ${LIBI2NCOMMON_LIBRARIES} ${Boost_LIBRARIES})
+target_link_libraries(libasyncio ${LIBI2NCOMMON_LIBRARIES} ${Boost_SIGNALS_LIBRARIES})
 
 # Headerlist
 foreach(header_file_in ${libasyncio_HEADERS})