Explicitly link pthread, needed by new binutils
[bpdyndnsd] / src / CMakeLists.txt
index 5bbe984..322372f 100644 (file)
@@ -70,7 +70,7 @@ set(cpp_headers
 add_executable(bpdyndnsd ${cpp_sources} ${cpp_headers})
 
 # Dependencies
-target_link_libraries(bpdyndnsd ${Boost_LIBRARIES} ${CURL_LIBRARIES} ${OPENSSL_LIBRARIES})
+target_link_libraries(bpdyndnsd ${Boost_LIBRARIES} ${CURL_LIBRARIES} ${OPENSSL_LIBRARIES} pthread)
 
 # Install
 install(TARGETS bpdyndnsd DESTINATION bin)