Fix 'occurred' typo
[bpdyndnsd] / bpdyndnsd.spec
... / ...
CommitLineData
1Name: bpdyndnsd
2Summary: bpdyndnsd - bullet proof dyndns update daemon
3Version: 1.1
4Release: 1
5License: GPLv2 + Linking Exception
6Group: Applications/Internet
7Vendor: Intra2net AG
8URL: www.intra2net.com
9Packager: Bjoern Sikora <bjoern.sikora@intra2net.com>
10Source: %{name}-%{version}.tar.gz
11PreReq: tar
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13BuildPreReq: cmake >= 2.6
14BuildRequires: boost-devel >= 1.37.0
15BuildRequires: curl-devel >= 7.19.6
16BuildRequires: openssl-devel >= 0.9.8k
17Requires: boost-serialization >= 1.37.0
18Requires: curl >= 7.19.6
19Requires: openssl >= 0.9.8k
20
21%description
22A bullet proof easy to use dynamic DNS update daemon. Although of the ease of use it's highly scalable and flexible for advanced configurations. At the moment it supports following protocols: DHS, DYNDNS, DYNS, EASYDNS, GNUDIP, ODS, TZO and ZONEEDIT. The IP address to update the dynamic DNS name can be determined either through the wan interface's IP itself or through a webcheck IP URL if located behind a NAT router. It's possible to use multiple services at the same time and for each configured service special parameters can be declared, such as the update interval, maximal number of updates within this interval or the DNS cache ttl. It's also possible to configure a HTTP proxy and the corresponding port. It fully supports IPv6.
23
24%prep
25%setup -q
26
27%build
28mkdir build
29cd build
30
31export CFLAGS="$RPM_OPT_FLAGS"
32export CXXFLAGS="$RPM_OPT_FLAGS"
33cmake -DCMAKE_INSTALL_PREFIX="/usr" ../
34
35make %{?_smp_mflags} VERBOSE=1
36
37%install
38cd build
39make DESTDIR=%{buildroot} install
40cd ..
41%{__mkdir_p} %{buildroot}/etc/bpdyndnsd
42install -m 640 config/bpdyndnsd.conf %{buildroot}/etc/bpdyndnsd/
43%{__mkdir_p} %{buildroot}/etc/init.d
44install -m 755 scripts/bpdyndnsd %{buildroot}/etc/init.d/
45%{__mkdir_p} %{buildroot}/usr/share/doc/%{name}-%{version}
46install -m 644 docs/* %{buildroot}/usr/share/doc/%{name}-%{version}/
47%{__mkdir_p} %{buildroot}/usr/share/doc/%{name}-%{version}/config_examples
48install -m 644 config_examples/* %{buildroot}/usr/share/doc/%{name}-%{version}/config_examples/
49%{__mkdir_p} %{buildroot}/etc/sysconfig
50install -m 644 config/bpdyndnsd %{buildroot}/etc/sysconfig/
51%{__mkdir_p} %{buildroot}/var/state/bpdyndnsd
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57/sbin/chkconfig --add bpdyndnsd
58/sbin/chkconfig --level 345 bpdyndnsd on
59
60%files
61%config(noreplace) /etc/bpdyndnsd/bpdyndnsd.conf
62%config(noreplace) /etc/sysconfig/bpdyndnsd
63/etc/init.d/bpdyndnsd
64/usr/bin/bpdyndnsd
65%doc /usr/share/doc/%{name}-%{version}
66%dir /var/state/bpdyndnsd