Moved into subfolder config.
[bpdyndnsd] / bpdyndnsd.spec
CommitLineData
9c525d5d
BS
1Name: bpdyndnsd
2Summary: bpdyndnsd - bullet proof dyndns update daemon
3Version: 0.1
4Release: 1
5License: GPLv2 + Linking Exception
6Group: Applications/Internet
7Vendor: Intra2net AG
8URL: www.intra2net.com
9Packager: Bjoern Sikora <bjoern.sikora@intra2net.com>
10Source: %{name}-%{version}.tar.gz
11PreReq: tar
12BuildRoot: /tmp/%{name}-%{version}-root
13BuildPreReq: cmake >= 2.6
14BuildRequires: boost-devel >= 1.37.0
15BuildRequires: libcurl-devel >= 7.19.6
16BuildRequires: openssl-devel >= 0.9.8k
17Requires: boost >= 1.37.0
18Requires: libcurl >= 7.19.6
19Requires: openssl >= 0.9.8k
20
21%description
22An bullet proof easy to use dynamic DNS update daemon. Although of the ease of use it's highly scalable and flexible for advanced configurations. At the moment it supports following protocols: DHS, DYNDNS, DYNS, EASYDNS, GNUDIP, ODS, TZO and ZONEEDIT. The IP address to update the dynamic DNS name can be determined either through the wan interface's IP itself or through a webcheck IP URL if located behind a NAT router. It's possible to use multiple services at the same time and for each configured service special parameters can be declared, such as the update interval, maximal number of updates in this interval or the DNS cache ttl. It's also possible to configure a HTTP proxy and the corresponding port. It fully supports IPv6.
23
24%prep
25%setup -q
26
27%build
28cd build
29cmake ..
30make
31
32%install
33make DESTDIR=%{buildroot} install
34%{__mkdir_p} %{buildroot}/etc/bpdyndnsd
35install -m 640 config/bpdyndnsd.conf %{buildroot}/etc/bpdyndnsd/
36%{__mkdir_p} %{buildroot}/etc/init.d
37install -m 755 scripts/bpdyndnsd %{buildroot}/etc/init.d/
38
39%clean
40#rm -rf $RPM_BUILD_ROOT
41
42%post
43/sbin/chkconfig --add bpdyndnsd
44/sbin/chkconfig --level 345 bpdyndnsd on
45
46%files
47/etc/bpdyndnsd/bpdyndnsd.conf
48/etc/init.d/bpdyndnsd
49/usr/local/bin/bpdyndnsd