libi2ncommon is no Intranator-specific lib anymore, it is open source. So don't insta...
[libi2ncommon] / libi2ncommon.spec
1 %bcond_with Intra2net
2 %bcond_with xmllib
3 %bcond_with imap_utf7_support
4
5 # Detect Intra2net build environment
6 %if %{with Intra2net}
7     %define with_xmllib 1
8     %define with_imap_utf7_support 1
9 %endif
10
11 Summary:   library with functions common in Intra2net programs
12 Name:      libi2ncommon
13 Version:   ##VERSION##
14 Release:   1
15 License:   GPLv2 + linking exception
16 Group:     Development/Libraries
17 Vendor:    Intra2net AG
18 Source:    %{name}-%{version}.tar.gz
19 Requires:  libi2ncommon-utils = %{version}
20 BuildPrereq: libtool
21 BuildRequires: boost-devel >= 1.32.0
22 Obsoletes: libgettext
23
24
25 %description 
26 library with functions common in Intra2net programs
27
28 %package   devel
29 Summary:   library with functions common in Intra2net programs
30 Group:     Intranator/Development
31 Requires:  libi2ncommon = %{version}
32 Requires: boost-devel >= 1.32.0
33
34
35 %description devel
36 library with functions common in Intra2net programs
37
38
39 %package config
40 Summary:    library with a config module
41 Group:      Intranator
42 Requires:   libi2ncommon = %{version}
43
44 %description config
45 library with a config module.
46 The config module provides a global configuration system with decentralized
47 declaration of the config variables.
48
49 %if %{with xmllib}
50 %package xml
51 Summary:    library with a xml module
52 Group:      Intranator
53 Requires:   libi2ncommon = %{version}
54
55 %description xml
56 The xml module provides common xml functions.
57 %endif
58
59 %package utils
60 Summary:    library with open source utility modules
61 Group:      Intranator
62 License:    GPL version 2 + linking exception
63
64 %description utils
65 Library with open source utility modules.
66
67 %prep
68 %setup -q
69
70 %build
71 export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/intranator/lib/pkgconfig
72
73 mkdir build
74 cd build
75
76 export CFLAGS="$RPM_OPT_FLAGS"
77 export CXXFLAGS="$RPM_OPT_FLAGS"
78
79 CMAKE_OPTS=""
80 %if %{with xmllib}
81     CMAKE_OPTS="$CMAKE_OPTS -DBUILD_XMLLIB=ON"
82 %endif
83 %if %{with imap_utf7_support}
84     CMAKE_OPTS="$CMAKE_OPTS -DIMAP_UTF7_SUPPORT=ON"
85 %endif
86
87 cmake -DCMAKE_INSTALL_PREFIX="%{prefix}" $CMAKE_OPTS ../
88
89 make %{?_smp_mflags} VERBOSE=1
90
91 %check
92 cd build
93 make check
94
95 %install
96
97 cd build
98 make DESTDIR=$RPM_BUILD_ROOT install
99
100 %clean
101 rm -fr $RPM_BUILD_ROOT
102
103 %post
104 /sbin/ldconfig
105
106 %files
107 %defattr(-,root,root)
108 %doc COPYING.GPL
109 %{_libdir}/libi2ncommon.so*
110
111 %files devel
112 %defattr(-,root,root)
113 # No static library for now
114 #%{prefix}/lib/*.*a*
115 %{_libdir}/libi2ncommon.so
116 %{_libdir}/pkgconfig/*.pc
117 %{prefix}/include/
118
119 %files config
120 %defattr(-,root,root)
121 %doc COPYING.GPL
122 %{_libdir}/libi2ncommon_config.so*
123
124 %if %{with xmllib}
125 %files xml
126 %defattr(-,root,root)
127 %doc COPYING.GPL
128 %{_libdir}/libi2ncommon_xml.so*
129 %endif
130
131 %files utils
132 %defattr(-,root,root)
133 %doc COPYING.GPL
134 %{_libdir}/libi2ncommon_utils.so*