Switch license from Intranator license to GPLv2 + linking exception (ACKed by Steffen)
[libi2ncommon] / libi2ncommon.spec
1 Summary:   library with functions common in Intra2net programs
2 Name:      libi2ncommon
3 Version:   ##VERSION##
4 Release:   1
5 License:   GPLv2 + linking exception
6 Group:     Intranator
7 Vendor:    Intra2net AG
8 Source:    %{name}-%{version}.tar.gz
9 Buildroot: /tmp/%{name}-%{version}-root
10 Prefix:    /usr/intranator
11 Requires:  libi2ncommon-utils = %{version}
12 BuildPrereq: libtool
13 BuildRequires: boost-devel >= 1.32.0
14 Obsoletes: libgettext
15
16
17 %description 
18 library with functions common in Intra2net programs
19
20 %package   devel
21 Summary:   library with functions common in Intra2net programs
22 Group:     Intranator/Development
23 Requires:  libi2ncommon = %{version}
24 Requires: boost-devel >= 1.32.0
25
26
27 %description devel
28 library with functions common in Intra2net programs
29
30
31 %package config
32 Summary:    library with a config module
33 Group:      Intranator
34 Requires:   libi2ncommon = %{version}
35
36 %description config
37 library with a config module.
38 The config module provides a global configuration system with decentralized
39 declaration of the config variables.
40
41 %package xml
42 Summary:    library with a xml module
43 Group:      Intranator
44 Requires:   libi2ncommon = %{version}
45
46 %description xml
47 The xml module provides common xml functions.
48
49 %package utils
50 Summary:    library with open source utility modules
51 Group:      Intranator
52 License:    GPL version 2 + linking exception
53
54 %description utils
55 Library with open source utility modules.
56
57 %prep
58 %setup -q
59
60 %build
61 export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/intranator/lib/pkgconfig
62
63 mkdir build
64 cd build
65
66 export CFLAGS="$RPM_OPT_FLAGS"
67 export CXXFLAGS="$RPM_OPT_FLAGS"
68 cmake -DCMAKE_INSTALL_PREFIX="%{prefix}" ../
69
70 make %{?_smp_mflags} VERBOSE=1
71
72 %check
73 cd build
74 make check
75
76 %install
77
78 cd build
79 make DESTDIR=$RPM_BUILD_ROOT install
80
81 %clean
82 rm -fr $RPM_BUILD_ROOT
83
84 %post
85 /sbin/ldconfig
86
87 %files
88 %defattr(-,root,root)
89 %doc COPYING.GPL
90 %{prefix}/lib/libi2ncommon.so*
91
92 %files devel
93 %defattr(-,root,root)
94 # No static library for now
95 #%{prefix}/lib/*.*a*
96 %{prefix}/lib/pkgconfig/*.pc
97 %{prefix}/include/
98
99 %files config
100 %defattr(-,root,root)
101 %doc COPYING.GPL
102 %{prefix}/lib/libi2ncommon_config.so*
103
104 %files xml
105 %defattr(-,root,root)
106 %doc COPYING.GPL
107 %{prefix}/lib/libi2ncommon_xml.so*
108
109 %files utils
110 %defattr(-,root,root)
111 %doc COPYING.GPL
112 %{prefix}/lib/libi2ncommon_utils.so*