libi2ncommon is no Intranator-specific lib anymore, it is open source. So don't insta...
[libi2ncommon] / libi2ncommon.spec
CommitLineData
80156cdf
TJ
1%bcond_with Intra2net
2%bcond_with xmllib
652f47a7 3%bcond_with imap_utf7_support
80156cdf
TJ
4
5# Detect Intra2net build environment
6%if %{with Intra2net}
7 %define with_xmllib 1
652f47a7 8 %define with_imap_utf7_support 1
80156cdf
TJ
9%endif
10
e93545dd
GE
11Summary: library with functions common in Intra2net programs
12Name: libi2ncommon
13Version: ##VERSION##
b599d4b1 14Release: 1
0e23f538 15License: GPLv2 + linking exception
f9f14e9c 16Group: Development/Libraries
e93545dd
GE
17Vendor: Intra2net AG
18Source: %{name}-%{version}.tar.gz
5ff2acd9 19Requires: libi2ncommon-utils = %{version}
e93545dd 20BuildPrereq: libtool
5ff2acd9 21BuildRequires: boost-devel >= 1.32.0
bb5b934a 22Obsoletes: libgettext
16c2256f 23
e93545dd
GE
24
25%description
26library with functions common in Intra2net programs
27
28%package devel
29Summary: library with functions common in Intra2net programs
30Group: Intranator/Development
5ff2acd9 31Requires: libi2ncommon = %{version}
16c2256f
RP
32Requires: boost-devel >= 1.32.0
33
e93545dd
GE
34
35%description devel
36library with functions common in Intra2net programs
37
23d53eb1
RP
38
39%package config
40Summary: library with a config module
41Group: Intranator
42Requires: libi2ncommon = %{version}
43
44%description config
45library with a config module.
46The config module provides a global configuration system with decentralized
47declaration of the config variables.
48
80156cdf 49%if %{with xmllib}
ce6792dd
TJ
50%package xml
51Summary: library with a xml module
52Group: Intranator
53Requires: libi2ncommon = %{version}
54
55%description xml
56The xml module provides common xml functions.
80156cdf 57%endif
23d53eb1 58
f3311b30
TJ
59%package utils
60Summary: library with open source utility modules
61Group: Intranator
62License: GPL version 2 + linking exception
63
64%description utils
65Library with open source utility modules.
66
e93545dd
GE
67%prep
68%setup -q
69
70%build
71export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/intranator/lib/pkgconfig
e93545dd 72
263b5807
TJ
73mkdir build
74cd build
75
76export CFLAGS="$RPM_OPT_FLAGS"
77export CXXFLAGS="$RPM_OPT_FLAGS"
80156cdf
TJ
78
79CMAKE_OPTS=""
80%if %{with xmllib}
81 CMAKE_OPTS="$CMAKE_OPTS -DBUILD_XMLLIB=ON"
82%endif
652f47a7
TJ
83%if %{with imap_utf7_support}
84 CMAKE_OPTS="$CMAKE_OPTS -DIMAP_UTF7_SUPPORT=ON"
85%endif
80156cdf
TJ
86
87cmake -DCMAKE_INSTALL_PREFIX="%{prefix}" $CMAKE_OPTS ../
263b5807
TJ
88
89make %{?_smp_mflags} VERBOSE=1
90
91%check
92cd build
93make check
e93545dd
GE
94
95%install
263b5807
TJ
96
97cd build
e93545dd
GE
98make DESTDIR=$RPM_BUILD_ROOT install
99
100%clean
101rm -fr $RPM_BUILD_ROOT
102
103%post
104/sbin/ldconfig
105
106%files
107%defattr(-,root,root)
0e23f538 108%doc COPYING.GPL
f9f14e9c 109%{_libdir}/libi2ncommon.so*
e93545dd
GE
110
111%files devel
112%defattr(-,root,root)
263b5807
TJ
113# No static library for now
114#%{prefix}/lib/*.*a*
f9f14e9c
GE
115%{_libdir}/libi2ncommon.so
116%{_libdir}/pkgconfig/*.pc
e93545dd 117%{prefix}/include/
23d53eb1
RP
118
119%files config
120%defattr(-,root,root)
0e23f538 121%doc COPYING.GPL
f9f14e9c 122%{_libdir}/libi2ncommon_config.so*
23d53eb1 123
80156cdf 124%if %{with xmllib}
ce6792dd
TJ
125%files xml
126%defattr(-,root,root)
0e23f538 127%doc COPYING.GPL
f9f14e9c 128%{_libdir}/libi2ncommon_xml.so*
80156cdf 129%endif
f3311b30
TJ
130
131%files utils
132%defattr(-,root,root)
0e23f538 133%doc COPYING.GPL
f9f14e9c 134%{_libdir}/libi2ncommon_utils.so*