libftdi Archives

Subject: Re: [EEPROM branch] Dynamic string offset calculation

From: Thomas Jarosch <thomas.jarosch@xxxxxxxxxxxxx>
To: libftdi@xxxxxxxxxxxxxxxxxxxxxxx
Date: Fri, 24 Sep 2010 11:40:50 +0200
On Friday, 24. September 2010 11:34:03 Uwe Bonnes wrote:
>     Thomas> I still have trouble reading the code because of the "k"
> bitmask Thomas> wraparound magic. Maybe we find a better name for it,
> like Thomas> "eeprom_size_limit"?
> It is used as a mask, either 0x7f on 46 type chips or 0xff for 56/66 type
> chips, what about "eeprom_size_mask".

Ehr, yes, that's what I had in mind. Let's stick to eeprom_size_mask.
I'll do the modification.

> But I agree, sensible names are the A and O of good documentation, but
> are hard to get by..

Exactly :)


libftdi - see for details.
To unsubscribe send a mail to libftdi+unsubscribe@xxxxxxxxxxxxxxxxxxxxxxx   

Current Thread