Small corrections. Compiles and builds.
[libt2n] / examples-codegen / example2 / CMakeLists.txt
index 7d4a461..9308cbe 100644 (file)
@@ -31,13 +31,11 @@ set(other_GROUP
     ${CMAKE_CURRENT_SOURCE_DIR}/other-1.cpp 
     ${CMAKE_CURRENT_SOURCE_DIR}/other-2.cpp
 )
-# headers declaring data types used as rpc arguments must be listed manually (???)
-# (in this example the class Foo)
-set(CPP_HEADERS
-    ${CMAKE_CURRENT_SOURCE_DIR}/foo.hxx
-)
+#set(CPP_HEADERS
+#    ${CMAKE_CURRENT_SOURCE_DIR}/foo.hxx
+#)
 # include CMake snippet doing all the magic
-include(${CMAKE_SOURCE_DIR}/../cmake/Libt2n.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Libt2n.cmake)
 # command groups are listed here (seperated by spaces)
 setup_libt2n(default other)
 
@@ -88,3 +86,4 @@ add_dependencies(libt2n-example2-server default_codegen_done other_codegen_done)
 # install(TARGETS other_client ARCHIVE DESTINATION lib)
 # install(TARGETS libt2n-example2-server DESTINATION bin)
 # install(FILES ${CPP_HEADERS} DESTINATION include)
+# install(PROGRAMS test DESTINATION ./)