Small corrections. Compiles and builds.
[libt2n] / examples-codegen / example2-client / CMakeLists.txt
index 59ebbe2..00d5315 100644 (file)
@@ -13,11 +13,11 @@ set(CPACK_SOURCE_IGNORE_FILES          "~$;\\\\.git;build;build-rpm")
 set(CPACK_SOURCE_PACKAGE_FILE_NAME     "${PROJECT_NAME}-${VERSION}")
 
 # Find external packages
-include(FindPkgConfig)
+# include(FindPkgConfig)
 
-pkg_check_modules(DEFAULT REQUIRED default=0.1)
-include_directories(${DEFAULT_INCLUDE_DIRS})
-link_directories(${DEFAULT_LIBRARY_DIRS})
+# pkg_check_modules(DEFAULT REQUIRED default=0.1)
+# include_directories(${DEFAULT_INCLUDE_DIRS})
+# link_directories(${DEFAULT_LIBRARY_DIRS})
 
 include(CPack)
 
@@ -30,7 +30,8 @@ set(libt2n_example2_client_SOURCES
 add_executable(libt2n-example2-client ${libt2n_example2_client_SOURCES})
 
 # Dependencies
-target_link_libraries(libt2n-example2-client ${DEFAULT_LIBRARIES})
+# target_link_libraries(libt2n-example2-client ${DEFAULT_LIBRARIES})
+target_link_libraries(libt2n-example2-client default)
 
 # Installation
 # install(TARGETS libt2n-example2-client DESTINATION bin)