provide m4 macro to make configure script of libt2n/codegen users simple
[libt2n] / example-codegen / configure.in
index fc39e9f..9f6da86 100644 (file)
@@ -6,14 +6,6 @@ AC_LANG_CPLUSPLUS
 AC_PROG_CXX
 AM_PROG_LIBTOOL
 
-
-dnl: todo wrap this in a m4 macro?
-
-PKG_CHECK_MODULES(LIBT2N, libt2n = 0.1)
-LIBT2N_CODEGEN=`$PKG_CONFIG --variable libt2n_codegen libt2n`
-LIBT2N_DATADIR=`$PKG_CONFIG --variable libt2n_datadir libt2n`
-LIBT2N_CLIENT_PCTEMPLATE="$LIBT2N_DATADIR/clientlib.pc.in"
-AC_SUBST(LIBT2N_CODEGEN)
-AC_SUBST(LIBT2N_CLIENT_PCTEMPLATE)
+LIBT2N_CHECK(libt2n > 0.1)
 
 AC_OUTPUT(Makefile)